Live Helper Chat support forum.. Old google groups forum can be found here

You are not logged in.

Announcement

#1 2021-04-03 00:23:47

nootkan
Member
Registered: 2021-04-02
Posts: 10

Resolved: What Older Version is Compatible with PHP 5.6?

Just signed up for the forum. 

What is the last stable version that supports php 5.6?  I installed live helper chat a number of years ago but cannot find my original zip file.

I found all the older versions on github but everyone of them say compatible with php 5.2 in the composer json file. So I don't know which one works on 5.6.

The server I am going to install on is "Cloud Linux" and they have patched all the known vulnerabilities for php 5.6 so that won't be an issue.  Not my choice but the client insists he has no choice.

I could download all the version 3x or 2x versions from github and try each one until I get the "won't work with current php version" error but thought someone here may remember what the version is for php 5.6 and save me some time.

I have also downloaded the latest version to install on a different server with php 7.2 and look forward to trying it again.   

Much appreciated and Thanks in advance.

Last edited by nootkan (2021-04-03 20:16:08)

Offline

#2 2021-04-03 05:09:58

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,477
Website

Re: Resolved: What Older Version is Compatible with PHP 5.6?

Atleast using
php74 phpcompatinfo-5.0.12.phar analyser:run . --output=compatinfo.log

It tells that even recent lhc version should run just fine with 5.6php version.

Requires PHP 5.6.0 (min), PHP 5.6.33 (max), PHP 5.6.0 (all)

Offline

#3 2021-04-03 19:17:24

nootkan
Member
Registered: 2021-04-02
Posts: 10

Re: Resolved: What Older Version is Compatible with PHP 5.6?

Thanks for your reply.  Also thanks for the ssh command.  Didn't even know about that one.  Will come in handy. 

I was confused by this statement on the website:
livehelper requirements

Also I am a little confused by the statement of how to browse to the path for installation.  I have uploaded it in mywebsite/livehelper/ but when I look at the path suggested on the install page it reads: Your browser is pointing to index.php/site_admin/install/install URL. 

After uploading zip files to remote server I don't see site_admin anywhere so not sure how to point to my path.

Did I do something wrong or misunderstanding something?

Offline

#4 2021-04-03 19:22:01

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,477
Website

Re: Resolved: What Older Version is Compatible with PHP 5.6?

Follow guide. If you look carefull index.php/site... is just an index.php argument
https://doc.livehelperchat.com/docs/install/

Offline

#5 2021-04-03 20:12:59

nootkan
Member
Registered: 2021-04-02
Posts: 10

Re: Resolved: What Older Version is Compatible with PHP 5.6?

It seems that my original ftp transfer was corrupt, as soon as I deleted everything and started over it all worked out.

I was just looking for a difficult issue when it turned out to be a simple one. Story of my life. wink wink

For anyone who may be wondering as I did this seems to install fine on php 5.6 and Mysql 5.7.

Thanks for the support much appreciated and may I say very impressive the amount of effort put into this script.  Kudos to the developer(s).

Looking forward to setting everything up and giving it a good workout.

Last edited by nootkan (2021-04-03 20:15:10)

Offline

#6 2021-04-05 05:21:30

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,477
Website

Re: Resolved: What Older Version is Compatible with PHP 5.6?

Just once you install make sure that you can start a chat and operator can write back smile

Offline

#7 2021-04-05 06:55:59

nootkan
Member
Registered: 2021-04-02
Posts: 10

Re: Resolved: What Older Version is Compatible with PHP 5.6?

Thanks for the reply. Yeah it is all good! Live Helper is working great. Just got to iron out some design issues.

Offline

Board footer