Live Helper Chat support forum.. Old google groups forum can be found here

You are not logged in.

Announcement

#1 2020-05-21 14:36:56

edersonbologna
Member
Registered: 2020-04-04
Posts: 23

Triggers are gone

Good Morning.
I was building List messages in a bot. Suddenly all triggers are gone. Both the bot that was working and the one that was completed. This is the second time this has happened.
Can you tell me how to retrieve the triggers for the two bots? And why does this error happen?

Offline

#2 2020-05-21 15:23:13

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 2,941
Website

Re: Triggers are gone

Well, fr me it does not happen. Never. If this happens try just refresh page. Also if you be able reproduce on demo or just dummy automated hosting I provide then I could try to fix. Without steps not mutch I can do.

P.s all triggers never dissapear unless you delete trigger group or bot itself.

Offline

#3 2020-05-21 15:48:40

edersonbologna
Member
Registered: 2020-04-04
Posts: 23

Re: Triggers are gone

remdex wrote:

Well, fr me it does not happen. Never. If this happens try just refresh page. Also if you be able reproduce on demo or just dummy automated hosting I provide then I could try to fix. Without steps not mutch I can do.

P.s all triggers never dissapear unless you delete trigger group or bot itself.

Worse they are gone. There are no records in the lh_generic_bot_trigger table. I imagine this is where they stay. It may be that the table has become corrupted. Or something else.

Offline

#4 2020-05-21 15:52:03

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 2,941
Website

Re: Triggers are gone

That’s really to strange big_smile if react app breaks triggers themself are never deleted. Especially from other bot big_smile Also for future you can just export bot to have a backup. And yes table is correct one. What where you doing exactly then they gone? Was it a button click or what. Also you can tey to look in http log for genericbot keyboard as all actions goes through this url. Also as for table it should be innodb engine always.

You can skype me perhaps i could help then. Atleast to check http log big_smile

Offline

#5 2020-05-23 08:16:50

Lilo
Member
Registered: 2015-02-26
Posts: 103

Re: Triggers are gone

I also noted triggers dissapearing and this happens when you have linked bots (if you change the trigger that links them then it disappear).

I can assume you had a long bot & do back ups as you proceed.

Offline

#6 2020-05-23 11:23:59

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 2,941
Website

Re: Triggers are gone

If you ciuld send apache log, when this is happening atleast that way i could try to understand what’s happening smile

Offline

#7 Yesterday 06:58:00

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 2,941
Website

Re: Triggers are gone

Hi,

Seems indeed for this just happened. But it only happens it seems MyIsam Table crashes. Make sure all tables are InnoDB engine!

Offline

#8 Yesterday 07:18:13

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 2,941
Website

Re: Triggers are gone

Hi,
Seems actually i found a bug! and that's a good news! we can fix it smile

Offline

#9 Yesterday 07:42:23

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 2,941
Website

Re: Triggers are gone

Please apply this one change. Issue was then i was removing payload it was removing all group triggers sad

https://github.com/LiveHelperChat/liveh … b2c3ebbf37

Offline

Board footer