Live Helper Chat support forum.. Old google groups forum can be found here

You are not logged in.

Announcement

#1 2020-04-02 02:27:26

billy.G
Member
Registered: 2020-04-02
Posts: 3

Dont work only the Icon appeared when page refresh - Click Disappeared

Hello,

I am using version 3.0.0 and then upgrade to version 3.29. upgrading is very easy following the instructions on the website.

If you embed the Widget embed code (legacy) code into your website (the domain itself), the code will work.

However, when specifying any domain (I tried pasting the code on 2 other domains), it did not work, ie it appeared ICON chat only, but when I clicked on ICON, it Disappeared, only the Icon appeared again when page refresh.

# of course I changed the Domain generating embed code to suit each domain and code.
# all are shared hosting, PHP 7.2, Linux and Apache

(?) I don't know how to fix it, please have a guide. Thanks !

Offline

#2 2020-04-02 04:06:33

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,142
Website

Re: Dont work only the Icon appeared when page refresh - Click Disappeared

Hi,

Without website really to hard to now. Ping me on skype nick - remdex.

Offline

#3 2020-04-02 06:39:49

PeopleInside
Administrator
From: Italy
Registered: 2014-04-10
Posts: 3,694
Website

Re: Dont work only the Icon appeared when page refresh - Click Disappeared

Hi billy.G, welcome on the live helper chat forum.
If you are using the new beta widget and the issue is only on external domain please see this:
28 - The new widget: how to add external webiste


lol PeopleInside - Live helper chat - free limited forum support!
wink For commercial support or GitHub [see FAQ here]
ops If you want to support this open source project, just donate [see support page]
glasses Something wrong with the forum? [contact a superhero]

Offline

#4 2020-04-14 01:29:55

billy.G
Member
Registered: 2020-04-02
Posts: 3

Re: Dont work only the Icon appeared when page refresh - Click Disappeared

remdex wrote:

Hi,

Without website really to hard to now. Ping me on skype nick - remdex.

So sorry, local testing only ... ! thanks.

PeopleInside wrote:

Hi billy.G, welcome on the live helper chat forum.
If you are using the new beta widget and the issue is only on external domain please see this:
28 - The new widget: how to add external webiste

Yes that's it, and how can i change "Widget position" like (legacy version) - thanks !

Offline

#5 2020-04-14 03:27:18

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,142
Website

Re: Dont work only the Icon appeared when page refresh - Click Disappeared

Hi,

Try to see this for not loading widget.
https://doc.livehelperchat.com/docs/ins … s-not-load

As for widget position you have to choose it in embed code generation.

Offline

#6 2020-04-15 10:15:07

billy.G
Member
Registered: 2020-04-02
Posts: 3

Re: Dont work only the Icon appeared when page refresh - Click Disappeared

remdex wrote:

As for widget position you have to choose it in embed code generation.

with Widget position 2 options : (1) default and (2) api, but position = 'api' When choosing the API, the Chat icon disappears, nothing is left.
How can you set this type (Middle left side of the screen)?

I found this API guide, but too confusing and could not find any signs of Position: doc.livehelperchat.com/docs/javascript-arguments/#public-methods

Thanks!

Last edited by billy.G (2020-04-15 10:20:45)

Offline

Board footer