Live Helper Chat support forum.. Old google groups forum can be found here

You are not logged in.

Announcement

#1 2019-08-20 17:03:32

bayanaask
Member
Registered: 2019-01-03
Posts: 42

Chat doesn't start and showing leave message form

I am trying to install new livechat version : Current version - 3.24. There is no required any updates on Livechat update section.

I was using 2.14 and everything was fine and I removed it. I already spent 2 days to figure out it, but no luck.

This is installed new version with 2 users. 1 is admin and another one is andrea. Both are testing users. Andrea assigned to Epoxytops department and Department has working hours. I already checked using the department working time on the status.
1566320637_111.jpg

When after working out it changes to Leave a message status. During the working time it shows Chat with us.
1566320651_112.jpg

but when i click on it, it shows the leave a message form.
1566320703_113.jpg

I am pretty sure i added WIDGET Embed code with department and my style. Actually it was fine before I remove all permission from List role, Because default list role doesn't provide to agent cannot reply message and cannot assign into any chat. Thats why I removed all roles and set roles same as v2.14. Also I gave them full LCHAT permission and solved the problem, but i am pretty sure its not good solution.

Thank you

Last edited by bayanaask (2019-08-20 17:05:07)

Offline

#2 2019-08-20 17:35:35

bayanaask
Member
Registered: 2019-01-03
Posts: 42

Re: Chat doesn't start and showing leave message form

Okey I just disabled GEO adjustment and everything is works fine. I have no idea how this GEO adjustment related to this.

Thank you

Offline

#3 2019-08-20 20:55:36

PeopleInside
Administrator
From: Italy
Registered: 2014-04-10
Posts: 3,496
Website

Re: Chat doesn't start and showing leave message form

Hi bayanaask, thank you for your message!
Strange issue but happy to know you have resolved!


lol PeopleInside - Live helper chat - free limited forum support!
wink For commercial support or GitHub [see FAQ here]
ops If you want to support this open source project, just donate [see support page]
glasses Something wrong with the forum? [contact a superhero]

Offline

#4 2019-08-20 20:58:01

bayanaask
Member
Registered: 2019-01-03
Posts: 42

Re: Chat doesn't start and showing leave message form

PeopleInside wrote:

Hi bayanaask, thank you for your message!
Strange issue but happy to know you have resolved!

Thanks for the reply. I have anther problem. I wanted to upload file into theme. before it was working fine but now it's not working. I tried to give any permission to those files but no luck. its on AWS and I read many solutions, but no luck.

AH01071: Got error 'PHP message: PHP Warning:  mkdir(): Permission denied in /opt/bitnami/apps/wordpress/htdocs/livechat/lib/core/lhcore/lhfileupload.php on line 139\nPHP message: PHP Warning:  mkdir(): Permission denied in /opt/bitnami/apps/wordpress/htdocs/livechat/lib/core/lhcore/lhfileupload.php on line 139\nPHP message: PHP Warning:  move_uploaded_file(var/storagetheme/2019y/08/20/5//0c47c10275e3c1d93e8489c04506b6a4.png): failed to open stream: No such file or directory in /opt/bitnami/apps/wordpress/htdocs/livechat/lib/core/lhcore/lhsearchhandler.php on line 566\nPHP message: PHP Warning:  move_uploaded_file(): Unable to move '/opt/bitnami/php/tmp/phpNicP0t' to 'var/storagetheme/2019y/08/20/5//0c47c10275e3c1d93e8489c04506b6a4.png' in /opt/bitnami/apps/wordpress/htdocs/livechat/lib/core/lhcore/lhsearchhandler.php on line 566\nPHP message: PHP Warning:  chmod(): No such file or directory in /opt/bitnami/apps/wordpress/htdocs/livechat/lib/core/lhcore/lhsearchhandler.php on line 567\n'


What do you think?

Offline

#5 2019-08-20 21:02:47

PeopleInside
Administrator
From: Italy
Registered: 2014-04-10
Posts: 3,496
Website

Re: Chat doesn't start and showing leave message form

I wanted to upload file into theme.

Are you trying to import a theme or what file?
Seems an issue with file permission. Is strange you are having all this issues.

Maybe this issue are related to the install made by the use of bitnami or you installed live helper chat manually by downloading the package on the official website?

Please remember support here is limited, i'm not a programmer or a technician of live helper chat just try to give a free basic help on my free times.
This errors seems related to your file permissions on your server.


lol PeopleInside - Live helper chat - free limited forum support!
wink For commercial support or GitHub [see FAQ here]
ops If you want to support this open source project, just donate [see support page]
glasses Something wrong with the forum? [contact a superhero]

Offline

#6 2019-08-20 21:06:29

bayanaask
Member
Registered: 2019-01-03
Posts: 42

Re: Chat doesn't start and showing leave message form

Yes it is from github latest version. Its from https://github.com/remdex/livehelpercha … master.zip

Yes I know it's related to server side, but I installed many plugins and many different packages, libraries and all working fine. I gave right permission and right group etc.
Now i have only 1 chance to replace the core code. If i fix it i will let you know. I am pretty sure i gave all correct permission to all folders and all files.



PeopleInside wrote:

I wanted to upload file into theme.

Are you trying to import a theme or what file?
Seems an issue with file permission. Is strange you are having all this issues.

Maybe this issue are related to the install made by the use of bitnami or you installed live helper chat manually by downloading the package on the official website?

Please remember support here is limited, i'm not a programmer or a technician of live helper chat just try to give a free basic help on my free times.
This errors seems related to your file permissions on your server.

Offline

#7 2019-08-20 21:28:09

bayanaask
Member
Registered: 2019-01-03
Posts: 42

Re: Chat doesn't start and showing leave message form

Sorry after deep research i found that LHSEARCHHANDLER.php and LHFILEUPLOAD.php created folder under different user and group. thats why it shows permission error. Next time i will reply after deep research.

Thank you

[unnecessary quote removed]

Last edited by PeopleInside (2019-08-20 21:35:32)

Offline

#8 2019-08-20 21:36:08

PeopleInside
Administrator
From: Italy
Registered: 2014-04-10
Posts: 3,496
Website

Re: Chat doesn't start and showing leave message form

Great, have a nice time.


lol PeopleInside - Live helper chat - free limited forum support!
wink For commercial support or GitHub [see FAQ here]
ops If you want to support this open source project, just donate [see support page]
glasses Something wrong with the forum? [contact a superhero]

Offline

#9 2019-11-26 23:42:18

aceletta
Member
Registered: 2019-11-26
Posts: 5

Re: Chat doesn't start and showing leave message form

Hi
I'm logged in as an administrator, but the Widget appears offline

Last edited by aceletta (2019-11-26 23:43:02)

Offline

#10 2019-11-27 10:25:41

PeopleInside
Administrator
From: Italy
Registered: 2014-04-10
Posts: 3,496
Website

Re: Chat doesn't start and showing leave message form

Hi aceletta, welcome on the live helper chat forum!
Please opened a new topic, i will close this as has been completed.

Please check your operator profile if is assigned or not to the department, also check other settings.


lol PeopleInside - Live helper chat - free limited forum support!
wink For commercial support or GitHub [see FAQ here]
ops If you want to support this open source project, just donate [see support page]
glasses Something wrong with the forum? [contact a superhero]

Offline

Board footer