Live Helper Chat support forum.. Old google groups forum can be found here

You are not logged in.

Announcement

#1 2019-09-26 16:58:11

Dem421
Member
Registered: 2018-06-19
Posts: 7

LHC performance issue

Hello everyone,

I have had performance problems in my LHC installation since last week, everything was going well until then. The loading of the chats on the initial screen began to take time to load, clicking on a chat to open it also took a long time and when sending a message (either from the operator or the user) it also remained frozen and It took a long time until it was sent.

The LHC version was 2.9.7, the PHP version was 5.6.40 and was running as a FastCgi application served by Apache. While the server it is hosted on has an Intel (R) Xeon (R) CPU E5-2660 v2 *** 2.20GHz (8 core (s)) processor with 16 GB of RAM, so it is not a problem with the capacity of the server.

Yesterday I was reviewing what I could do and saw that there was a new version of LHC (3.2.5). And looking at the changes made since version 2.9.7 I saw that there were improvements in performance so I decided to update the version. I also updated the version of PHP that it uses to 7.2.22. But once the web is updated, I see that everything is still very slow (loading chats on the initial screen, loading a chat and sending messages in the chat).

It is not a website that is having an intensive use, it has been working for more than a year and it does not even have 1,000 chats with 3 operators so I do not understand where the performance problems can come from. It is true that we do not archive the chats because we need them to be accessible from the API.

I would be very grateful if you could tell me what I can do to return to normal web performance.

Thank you in advance,

Offline

#2 2019-09-27 13:14:35

Lilo
Member
Registered: 2015-02-26
Posts: 89

Re: LHC performance issue

Hi Dem421
Update to new version and see if you still experience the same problems

Offline

#3 2019-09-27 15:02:01

Dem421
Member
Registered: 2018-06-19
Posts: 7

Re: LHC performance issue

Hi Lilo,

As I said in the post, I already updated to the latest version (3.2.5) but it has not worked, it still works just as slowly.

Thank you for your comment.

Offline

#4 2019-10-01 06:56:31

Dem421
Member
Registered: 2018-06-19
Posts: 7

Re: LHC performance issue

Hello again,

I've been doing more tests but I still can't improve performance. I can't see why the performance is so slow.

Any idea how I can fix it?

Thank you,

Offline

Board footer