Live Helper Chat support forum.. Old google groups forum can be found here

You are not logged in.

Announcement

#1 2021-02-16 06:43:28

Snake19
New member
Registered: 2020-10-23
Posts: 7

SSO (Single sign-on)

Hello.
I need help with configuration SSO extension.
What I did by now:
1) I cloned singlesignon to lhc_web\extension (github.com/LiveHelperChat/livehelperchat-extensions/tree/master/singlesignon)
2) I added extension to settings.ini.php -
'extensions' =>
        array (
            'singlesignon'
        ),
3) I cloned simplesamlphp to lhc_web\extension (github.com/simplesamlphp/simplesamlphp)

When I start lhc (localhost/index.php/site_admin/) I get error:

2021/02/16 11:35:47 [error] 14708#0: *1 FastCGI sent in stderr: "PHP Warning:  include(../../simplesamlphp/lib/_autoload.php): failed to open stream: No such file or directory in C:\nginx\html\live-helper-chat\lhc_web\extension\singlesignon\modules\lhuser\login.php on line 24
PHP Warning:  include(): Failed opening '../../simplesamlphp/lib/_autoload.php' for inclusion (include_path='.;C:\php\pear') in C:\nginx\html\live-helper-chat\lhc_web\extension\singlesignon\modules\lhuser\login.php on line 24
Error: Class 'SimpleSAML_Auth_Simple' not found in C:\nginx\html\live-helper-chat\lhc_web\extension\singlesignon\modules\lhuser\login.php:27
Stack trace:
#0 C:\nginx\html\live-helper-chat\lhc_web\lib\core\lhcore\lhmodule.php(96): include()
#1 C:\nginx\html\live-helper-chat\lhc_web\lib\core\lhcore\lhmodule.php(555): erLhcoreClassModule::runModule()
#2 C:\nginx\html\live-helper-chat\lhc_web\index.php(50): erLhcoreClassModule::moduleInit()
#3 {main}" while reading response header from upstream, client: 127.0.0.1, server: 172.30.9.15, request: "GET /index.php/site_admin/user/login HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "localhost"

1613457110_111.jpg

I searched this post (simplesamlphp.org/docs/stable/simplesamlphp-sp-api) and find out that class should be "new \SimpleSAML\Auth\Simple('default-sp');" in lhc_web\extension\singlesignon\modules\lhuser\login.php.
But I get "Error: Class 'SimpleSAML\Auth\Simple' not found in C:\nginx\html\live-helper-chat\lhc_web\extension\singlesignon\modules\lhuser\login.php:27"

Did I get something wrong?

Offline

#2 2021-02-16 06:46:53

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,481
Website

Re: SSO (Single sign-on)

You have to provide correct path to the library
https://github.com/LiveHelperChat/liveh … ini.php#L4

Offline

#3 2021-02-16 08:13:31

Snake19
New member
Registered: 2020-10-23
Posts: 7

Re: SSO (Single sign-on)

You are right. I sent pull request to you.
Now I need to operator chat with visitor using SSO. What should I do? Any configuration tips?
Chat with bot open on http://localhost/index.php/. But when I enter http://localhost/index.php/site_admin/ it redirects me on http://localhost/index.php. How can I enter to the settings?

Offline

#4 2021-02-16 08:15:22

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,481
Website

Re: SSO (Single sign-on)

Try to see cache/default.log as if not logged you atleasty should see login form. also you can enable debug output.

Offline

#5 2021-02-16 08:36:50

Snake19
New member
Registered: 2020-10-23
Posts: 7

Re: SSO (Single sign-on)

I don't have cache/default.log file. I switch off cache in settings.
When I enable debug output chat with bot doesn't load properly - only header load and you can't send message.
And in both ways I've got this error in my log:
2021/02/16 13:26:16 [error] 18044#0: *1 FastCGI sent in stderr: "PHP Notice:  Undefined index: render_args in C:\nginx\html\live-helper-chat\lhc_web\lib\core\lhgenericbot\actionTypes\lhgenericbotactiontext.php on line 47
PHP Notice:  Undefined index: render_args in C:\nginx\html\live-helper-chat\lhc_web\lib\core\lhgenericbot\actionTypes\lhgenericbotactiontext.php on line 47" while reading response header from upstream, client: 127.0.0.1, server: 172.30.9.15, request: "POST /index.php/eng/widgetrestapi/submitonline HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "localhost", referrer: "http://localhost/index.php/"

How that extension should work?

Offline

#6 2021-02-16 08:54:13

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,481
Website

Re: SSO (Single sign-on)

Login workflow has to be initialised from third party URL and SSO parameters passed to http://localhost/index.php/site_admin/user/login

Offline

Board footer