Live Helper Chat support forum.. Old google groups forum can be found here

You are not logged in.

Announcement

#1 2019-12-08 18:26:03

magoo
Member
Registered: 2019-12-08
Posts: 4

Upgrade php 7.0 to 7.2 error

Greetings,

My previous version of PHP was 7.0. I upgraded the site to 7.2 and now LHC will not take input either through the dedicated page or embed code.
I did enable debugging in an attempt to re-mediate the issue. In summary, I have the following response:

Any idea?

Error Object
(
    [message:protected] => Call to undefined function mb_strlen()
    [string:Error:private] =>
    [code:protected] => 0
    [file:protected] => /home/kbmagoosvc/public_html/chat/lib/core/lhchat/lhchatvalidator.php
    [line:protected] => 288
    [trace:Error:private] => Array
        (
            [0] => Array
                (
                    [file] => /home/kbmagoosvc/public_html/chat/cache/compiledtemplates/b09a70a68bd480c629149d8c5b622c51.php
                    [line] => 2
                    [function] => validateStartChat
                    [class] => erLhcoreClassChatValidator
                    [type] => ::
                    [args] => Array
                        (

Offline

#2 2019-12-08 18:29:08

PeopleInside
Administrator
From: Italy
Registered: 2014-04-10
Posts: 3,527
Website

Re: Upgrade php 7.0 to 7.2 error

Hi magoo, welcome on the live helper chat forum!

Please be sure to use an updated version of live helper chat. The last version is 3.25.
I suppose your install can be too old, what version of LHC are you using?


lol PeopleInside - Live helper chat - free limited forum support!
wink For commercial support or GitHub [see FAQ here]
ops If you want to support this open source project, just donate [see support page]
glasses Something wrong with the forum? [contact a superhero]

Offline

#3 2019-12-08 18:31:44

magoo
Member
Registered: 2019-12-08
Posts: 4

Re: Upgrade php 7.0 to 7.2 error

I am using 3.25, and cleared the cache while testing the issue.

Offline

#4 2019-12-08 18:37:54

PeopleInside
Administrator
From: Italy
Registered: 2014-04-10
Posts: 3,527
Website

Re: Upgrade php 7.0 to 7.2 error

This is strange.
Do you have a backup? Maybe your upgrading process simply get wrong somewhere.

I suggest to resume the backup then try again. Be sure all necessary folders are transferred and be sure to not upload unnecessary folders.
https://livehelperchat.com/article/view/63

The error is showed in the widget on website side?
Have you checked your server error logs?

I'm starting a chat in your website (email domain) and i cannot see any error.


lol PeopleInside - Live helper chat - free limited forum support!
wink For commercial support or GitHub [see FAQ here]
ops If you want to support this open source project, just donate [see support page]
glasses Something wrong with the forum? [contact a superhero]

Offline

#5 2019-12-08 18:55:01

magoo
Member
Registered: 2019-12-08
Posts: 4

Re: Upgrade php 7.0 to 7.2 error

I have upgraded to version 7.3 but still seem to be encountering issues.

Error Object
(
    [message:protected] => Call to undefined function mb_strlen()
    [string:Error:private] =>
    [code:protected] => 0
    [file:protected] => /home/kbmagoosvc/public_html/chat/lib/core/lhchat/lhchatvalidator.php
    [line:protected] => 288
    [trace:Error:private] => Array
        (
            [0] => Array
                (
                    [file] => /home/kbmagoosvc/public_html/chat/cache/compiledtemplates/a6e160be59ee0b1f604f77153d6491c8.php

Offline

#6 2019-12-08 19:52:19

PeopleInside
Administrator
From: Italy
Registered: 2014-04-10
Posts: 3,527
Website

Re: Upgrade php 7.0 to 7.2 error

Hi, this seems an error with files.
Please as suggested try to restore the previous version from backup.

The previous version work on PHP 7.3?
What steps did you follow for upgrade?

Please try to upgrade again and be sure all file is uploaded correctly.


lol PeopleInside - Live helper chat - free limited forum support!
wink For commercial support or GitHub [see FAQ here]
ops If you want to support this open source project, just donate [see support page]
glasses Something wrong with the forum? [contact a superhero]

Offline

#7 2019-12-08 19:53:45

PeopleInside
Administrator
From: Italy
Registered: 2014-04-10
Posts: 3,527
Website

Re: Upgrade php 7.0 to 7.2 error

Try to search on Google regarding the error:  [message:protected] => Call to undefined function mb_strlen()
I found this: https://stackoverflow.com/questions/641 … -mb-strlen
but you can find more results on Google.

Is maybe PHP missing some extensions or components?


lol PeopleInside - Live helper chat - free limited forum support!
wink For commercial support or GitHub [see FAQ here]
ops If you want to support this open source project, just donate [see support page]
glasses Something wrong with the forum? [contact a superhero]

Offline

#8 2019-12-08 19:54:08

magoo
Member
Registered: 2019-12-08
Posts: 4

Re: Upgrade php 7.0 to 7.2 error

There was no upgrade. I simply changed the php version for the website, so no modifications to the site, code, or etc.
Do you want me to reinstall LHC?

Offline

#9 2019-12-08 19:55:49

PeopleInside
Administrator
From: Italy
Registered: 2014-04-10
Posts: 3,527
Website

Re: Upgrade php 7.0 to 7.2 error

In this case can be something missing on the new PHP version installed.
See my previous reply: https://forum.livehelperchat.com/viewto … 646#p13646


lol PeopleInside - Live helper chat - free limited forum support!
wink For commercial support or GitHub [see FAQ here]
ops If you want to support this open source project, just donate [see support page]
glasses Something wrong with the forum? [contact a superhero]

Offline

Board footer