Live Helper Chat support forum.. Old google groups forum can be found here

You are not logged in.

Announcement

#1 2019-03-11 21:03:40

richardspm
Member
Registered: 2019-03-11
Posts: 5

Dashboard Empty After Migration

Hello! I just migrated my livechat from ubuntu 16 to rhel 7, with cPanel.
Everything transferred over alright, user accounts, settings, etc.. but now the dashboard isn't displaying active and pending chats on its own.
However, if I change some of the settings for which chats to display, it sends the request and displays the active and pending chats, and updates them as it should.

On the network requests for the initial page load, there is a 500 error for a request to index.php/site_admin/chat/loadinitialdata/(chatopen)/   followed by 4 digit what I presume are user IDs.

However once I update some settings, it starts making regular requests to index.php/site_admin/chat/syncadmininterface

I assume loadinitialdata makes the initial call to syncadmininterface, where it runs on a timer after that?

In my logs I'm getting an error exception 'PDOException' with message 'SQLSTATE[HY000] [2002] Connection refused' in <my_document_root>/ezcomponents/Database/src/handler.php:88
If that's connection error is why loadinitialdata is failing, any ideas why it would fail here but not anywhere else where data is being retrieved?

Any insight appreciated, really appreciate how active you guys are on the forum.
Paul

Offline

#2 2019-03-11 21:29:50

PeopleInside
Administrator
From: Italy
Registered: 2014-04-10
Posts: 3,336
Website

Re: Dashboard Empty After Migration

Hi Paul ( richardspm ) , welcome on the live helper chat forum!
What version of Live Helper Chat, PHP and Mysql are you using?

I upgraded your forum account to Member group. Can you share the URL where your chat installation is?
You can maybe try to activate debug output https://livehelperchat.com/how-to-enabl … t-58a.html

Have you manually edited the database?

You can try to Google the error 'SQLSTATE[HY000] [2002] Connection refused'


lol PeopleInside - Live helper chat - free limited forum support!
wink For commercial support or GitHub [see FAQ here]
ops If you want to support this open source project, just donate [see support page]
glasses Something wrong with the forum? [contact a superhero]

Offline

#3 2019-03-11 21:40:36

richardspm
Member
Registered: 2019-03-11
Posts: 5

Re: Dashboard Empty After Migration

So the server that is hosting the admin panel is PHP 5.6.4, MySQL 5.7.25.
A lot of the websites that we have chat widgets on are php 5.3. Would we be able to upgrade to a newer livehelper version, or does it require 5.6+ on every server that makes requests.

Anyway the URL is installed at https://support.napc.pro/chatsupport/
Ill enable debug now and see what we get.

I haven't modified the database, I just made a dump file of it, transferred it to the other server, and made a user with identical credentials and permissions. I know it can at least access the database because all the user and department info and old chats are there though. Didn't find any googles for the SQLSTATE error that are only caused by a single page, since every other page can access the DB.

Thanks for the upgrade!
Paul

Offline

#4 2019-03-11 21:44:46

PeopleInside
Administrator
From: Italy
Registered: 2014-04-10
Posts: 3,336
Website

Re: Dashboard Empty After Migration

Hi Paul, PHP 5.6 support only security update is an old PHP version no more supported maybe from the last release of live helper chat.
What version of live helper chat are you running?

In any case maybe the database import has been not done successfully?
Seems the error is only a SQL error? Do you have PHP error or server error log file with other errors?
I cannot do much more for help you. Consider the suggestion to search on Google on my previous reply.

If you need a commercial support (not provided be me) you can find more info on my forum signature.


lol PeopleInside - Live helper chat - free limited forum support!
wink For commercial support or GitHub [see FAQ here]
ops If you want to support this open source project, just donate [see support page]
glasses Something wrong with the forum? [contact a superhero]

Offline

#5 2019-03-12 09:45:44

richardspm
Member
Registered: 2019-03-11
Posts: 5

Re: Dashboard Empty After Migration

Found a solution! I tested the request that was getting the 500 error, index.php/site_admin/chat/loadinitialdata/(chatopen)/4984/4992/4993/4995/4990/4989/4988/4983/4987/4982/4981/4985/4980
Found it returned json data if I removed the (chatopen) section of the URL, so I modified angular.lhc.js in the design/mysite/js folder, removed the part of the function that appends "(chatopen)/", and it's working again.
Bit of an odd fix, especially since it was working with the same exact files on a different folder, but if anyone runs into the same problem that did it for me.
Thanks again!

Offline

#6 2019-03-12 10:09:52

PeopleInside
Administrator
From: Italy
Registered: 2014-04-10
Posts: 3,336
Website

Re: Dashboard Empty After Migration

Hi richardspm , thank you for the updates!
I am happy to read you was able to resolve!

Enjoy and have a great time!


lol PeopleInside - Live helper chat - free limited forum support!
wink For commercial support or GitHub [see FAQ here]
ops If you want to support this open source project, just donate [see support page]
glasses Something wrong with the forum? [contact a superhero]

Offline

#7 2019-03-12 19:04:20

richardspm
Member
Registered: 2019-03-11
Posts: 5

Re: Dashboard Empty After Migration

I am having a similar problem as well though, currently users can start a chat, and the operator can respond as many times as they wish, but users cannot send additional messages beyond the one that starts the chat. This time the error seems to be at the module addmsguser. Any ideas? Maybe a permissions thing?

I'm able to rate the chat as thumbs up, it's just the message add that's having an issue

Also are you sure PHP 5.6.4 isn't supported by the latest version? The requirements page says "PHP 5.5 >= version"

Last edited by richardspm (2019-03-12 19:08:18)

Offline

#8 2019-03-12 19:33:27

PeopleInside
Administrator
From: Italy
Registered: 2014-04-10
Posts: 3,336
Website

Re: Dashboard Empty After Migration

Hi richardspm , I suggest to upgrade the PHP version as some user has solved in this way.
You can try to enable the debug output but maybe the issue can be also done by the PHP version.

http://php.net/supported-versions.php


lol PeopleInside - Live helper chat - free limited forum support!
wink For commercial support or GitHub [see FAQ here]
ops If you want to support this open source project, just donate [see support page]
glasses Something wrong with the forum? [contact a superhero]

Offline

#9 2019-03-12 19:52:09

richardspm
Member
Registered: 2019-03-11
Posts: 5

Re: Dashboard Empty After Migration

Upgraded to PHP7, no fix. Can I upgrade LHC if I'm running PHP7 on the hosting server, but PHP 5.3 on some of the websites that contain chat widgets?

Offline

#10 2019-03-12 20:51:12

PeopleInside
Administrator
From: Italy
Registered: 2014-04-10
Posts: 3,336
Website

Re: Dashboard Empty After Migration

richardspm PHP 5.3 ? Maybe you mean 5.6 I hope.
Your LHC install is migrated recently or is a new installation?

You can use debug. If you are able to reproduce the issue on the demo or on a new install maybe i can help more.
If you need custom support that i cannot give (as my support is imitated on my knowledge) you can follow links on my forum signature


lol PeopleInside - Live helper chat - free limited forum support!
wink For commercial support or GitHub [see FAQ here]
ops If you want to support this open source project, just donate [see support page]
glasses Something wrong with the forum? [contact a superhero]

Offline

Board footer