Live Helper Chat support forum.. Old google groups forum can be found here

You are not logged in.

Announcement

#1 2018-07-03 13:34:21

leozanutto
Member
Registered: 2017-01-23
Posts: 3

LHC configured over 2 servers with loadbalance

I have LHC configured over 2 servers some times I get css js php errors (cache/compiledTemplates/* NOT FOUND)

Inspecting the cache/compiledtemplates folder I discovered that files don't stay there much time like 10 seconds, then are deleted that's normal?
Because in my concept if you have a cache folder the main objective is to keep static content not being processed all the time.


I don't know if this is because of the 2 servers hosting, I don't see that behavior outside my production environment.
when disabling
'templatecache' => false,
'templatecompile' => false,
'modulecompile' => false,
the problem seens to go away at least less recurrent


Error that I get bellow :
1530624554_chaterror.png

sorry for bad english(not my native language).

Last edited by leozanutto (2018-07-03 13:35:36)

Offline

#2 2018-07-03 13:36:28

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 2,669
Website

Re: LHC configured over 2 servers with loadbalance

Hi,

This is known dependency. Please enable sticky sessions. Because then chat is cleared and it tries to find compiled template from another server. CSS/JS may not be compiled on another server. In AWS environment this is solved by enabling sticky sessions for 5 minutes or so. smile

Offline

#3 2018-07-03 17:27:50

leozanutto
Member
Registered: 2017-01-23
Posts: 3

Re: LHC configured over 2 servers with loadbalance

Actually I'm using a shared drive so the 2 servers access the same directory. (sticky sessions already configured)

I'm rewriting some part of the code so the cache generates per server.

Offline

Board footer