Live Helper Chat support forum.. Old google groups forum can be found here

You are not logged in.

Announcement

#1 2015-06-16 14:56:11

ipso
Member
Registered: 2015-06-16
Posts: 10

PostgreSQL upgrade support?

Just curious, it appears that the PostgreSQL branch doesn't have any kind of upgrade functionality, it seems like it runs pretty well though, so are there any near-term plans to add full PostgreSQL support?

Offline

#2 2015-06-16 18:22:44

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,631
Website

Re: PostgreSQL upgrade support?

Hi,

At the moment not, unless someone will make it. The only way is just track what changes i make in default schema file.

Offline

#3 2015-06-16 20:19:08

ipso
Member
Registered: 2015-06-16
Posts: 10

Re: PostgreSQL upgrade support?

I would be willing to help with the goal of merging the PostgreSQL changes into the master branch so its treated equally with MySQL.

It appears that the ezComponents framework that you use has support for abstracting out the schema to a XML file and handling all the upgrades itself, is there a reason you aren't using that functionality?

When I tried to research this framework it appears that the last release was way back in 2010, that concerns me quite a bit, is this framework essentially dead now?

Last edited by ipso (2015-06-16 22:36:05)

Offline

#4 2015-06-17 05:00:03

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,631
Website

Re: PostgreSQL upgrade support?

It's now called ZetaComponents https://github.com/zetacomponents

The reason this branch cannot be merged back to master is that update mechanism has to be different and post file descriptions are different structure.
Mysql version
https://github.com/LiveHelperChat/liveh … elchat.php

PostgreSQL version
https://github.com/LiveHelperChat/liveh … elchat.php

As for framework itself, I just basically just few main components like database, ORM and few others perhaps. As long it satisfies me I do not see a point to migrate to anywhere else smile

Offline

#5 2015-06-17 15:00:44

ipso
Member
Registered: 2015-06-16
Posts: 10

Re: PostgreSQL upgrade support?

remdex wrote:

It's now called ZetaComponents https://github.com/zetacomponents

The reason this branch cannot be merged back to master is that update mechanism has to be different and post file descriptions are different structure.
Mysql version
https://github.com/LiveHelperChat/liveh … elchat.php

PostgreSQL version
https://github.com/LiveHelperChat/liveh … elchat.php

Sorry, I don't understand what you mean why they can't be merged together? I realize that without changes, they can't be merged together, but are you planning on keeping them separate forever?

I have converted many projects to support multiple databases and its usually not a difficult task, but if the code is kept in separate trees its always a nightmare to work with and the other databases are never kept in a working state long-term.

Offline

#6 2015-06-17 18:28:00

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,631
Website

Re: PostgreSQL upgrade support?

Well, if you manage after merging run it on both database you are free to create pull request, i'll be happy to accept it smile

Offline

#7 2015-06-17 19:26:40

ipso
Member
Registered: 2015-06-16
Posts: 10

Re: PostgreSQL upgrade support?

Okay, so I'm still not sure why you aren't using the DatabaseSchema class in ezComponents to handle creating/upgrading the database schemas for you automatically?

Would it be possible to chat with you in real-time on IRC or Google Talk, we would like to help with the PostgreSQL support, but we want to do it in a way that is acceptable to you, so it would be nice to discuss some ideas before we do the work to implement them.

Offline

#8 2015-06-17 19:43:03

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,631
Website

Re: PostgreSQL upgrade support?

I'm always available on skype. But 99% i won't change the way current database schemas are defined. Just to many users are using the way it is defined now.

Offline

#9 2015-06-17 19:45:59

ipso
Member
Registered: 2015-06-16
Posts: 10

Re: PostgreSQL upgrade support?

Could you private message me your Skype ID please?

Regarding the current schema implementation, if the ezComponents DatabaseSchema class works the way it should, in theory switching to it it would still be backwards compatible. Of course we don't want to break existing installs, but if we can simplify the database maintenance burden especially across multiple databases that seems like a good thing to do, doesn't it?

Offline

Board footer