Live Helper Chat support forum.. Old google groups forum can be found here

You are not logged in.

Announcement

#1 2021-11-05 13:38:33

opsol
New member
Registered: 2021-11-05
Posts: 3

bot parse variables {{msg_all}} domain for file not showing

when chat is closed i trigger bot for parse variables {{msg_all}} to rest api . where the content of the chat is in images and files, but return variables {{msg_all}} sent by bot file url without domain. how do i get chat contents with full file url on another server domain ?

1636119134_screenshot_2021-11-05_203157.jpg

1636119304_screenshot_2021-11-05_203445.jpg

Offline

#2 2021-11-05 13:44:31

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,544
Website

Re: bot parse variables {{msg_all}} domain for file not showing

Are you sending this request via php-resque?

Offline

#3 2021-11-05 13:52:22

opsol
New member
Registered: 2021-11-05
Posts: 3

Re: bot parse variables {{msg_all}} domain for file not showing

remdex wrote:

Are you sending this request via php-resque?


i following tutorial github.com/LiveHelperChat/lhc-php-resque

1636120327_screenshot_2021-11-05_204708.jpg

Last edited by opsol (2021-11-05 13:53:04)

Offline

#4 2021-11-05 13:53:00

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,544
Website

Re: bot parse variables {{msg_all}} domain for file not showing

ok, it's a bug. I'm making changes now should go live in a hour or so. Will let you know here.

Offline

#5 2021-11-05 13:59:23

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,544
Website

Re: bot parse variables {{msg_all}} domain for file not showing

Please apply this fix https://github.com/LiveHelperChat/liveh … eb7719f5a4

Also make sure you have set domain in https://github.com/LiveHelperChat/lhc-p … ult.php#L8

`settings.ini.php` should be file, not default smile also php-resques needs to be restarted smile

Offline

#6 2021-11-08 04:42:32

opsol
New member
Registered: 2021-11-05
Posts: 3

Re: bot parse variables {{msg_all}} domain for file not showing

thanks for the fix.

I tried to send the variable {{msg_all}} to email with the content type text/plain but when the mouse hovers over the text link it includes the date below it.
1636346426_screenshot_2021-11-08_111830.jpg

and I try to send variable {{msg_all_html}} to email with content type text/html but image no display
1636346519_html_img.jpg

Offline

#7 2021-11-08 05:26:30

remdex
Administrator
From: Lithuania
Registered: 2012-09-23
Posts: 3,544
Website

Re: bot parse variables {{msg_all}} domain for file not showing

Hi,

Sorry but this time I don't understand the problem. You will have to paste the full HTML of the e-mail to prove that something is not right.

Offline

Board footer